05. What are the minimum browser requirements to use Learning Port Interactive?

Learning Port Interactive does not work on Internet Explorer and older versions of Google Chrome and Mozilla Firefox. We recommend latest versions of Google Chrome and Mozilla Firefox.